9219c1c09744d6ee69b50c3f6db968c42fb7333d
[gentoo.git] / dev-texlive / texlive-metapost / texlive-metapost-2015.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 TEXLIVE_MODULE_CONTENTS="automata bbcard blockdraw_mp bpolynomial cmarrows drv dviincl emp epsincl expressg exteps featpost feynmp-auto garrigues gmp hatching latexmp mcf2graph metago metaobj metaplot metapost metauml mfpic mfpic4ode mp3d mpcolornames mpattern mpgraphics piechartmp repere roex slideshow splines suanpan textpath threeddice collection-metapost
8 "
9 TEXLIVE_MODULE_DOC_CONTENTS="automata.doc bbcard.doc blockdraw_mp.doc bpolynomial.doc cmarrows.doc drv.doc dviincl.doc emp.doc epsincl.doc expressg.doc exteps.doc featpost.doc feynmp-auto.doc garrigues.doc gmp.doc hatching.doc latexmp.doc mcf2graph.doc metago.doc metaobj.doc metaplot.doc metapost.doc metauml.doc mfpic.doc mfpic4ode.doc mp3d.doc mpcolornames.doc mpattern.doc mpgraphics.doc piechartmp.doc repere.doc slideshow.doc splines.doc suanpan.doc textpath.doc threeddice.doc "
10 TEXLIVE_MODULE_SRC_CONTENTS="emp.source expressg.source feynmp-auto.source gmp.source mfpic.source mfpic4ode.source mpcolornames.source mpgraphics.source roex.source splines.source "
11 inherit  texlive-module
12 DESCRIPTION="TeXLive MetaPost and Metafont packages"
13
14 LICENSE=" BSD GPL-1 GPL-2 LGPL-2 LPPL-1.3 public-domain TeX-other-free "
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
17 IUSE=""
18 DEPEND=">=dev-texlive/texlive-basic-2015
19 "
20 RDEPEND="${DEPEND} "
21
22 # This small hack is needed in order to have a sane upgrade path:
23 # the new TeX Live 2009 metapost produces this file but it is not recorded in
24 # any package; when running fmtutil (like texmf-update does) this file will be
25 # created and cause collisions.
26
27 pkg_setup() {
28         if [ -f "${ROOT%/}${EPREFIX}/var/lib/texmf/web2c/metapost/mplib-luatex.mem" ]; then
29                 einfo "Removing ${ROOT%/}${EPREFIX}/var/lib/texmf/web2c/metapost/mplib-luatex.mem"
30                 rm -f "${ROOT%/}${EPREFIX}/var/lib/texmf/web2c/metapost/mplib-luatex.mem"
31         fi
32 }