dev-tex/latex-beamer: migrate from dev-tex/xcolor
[gentoo.git] / dev-tex / latex-beamer / latex-beamer-3.56-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit latex-package
7
8 DESCRIPTION="LaTeX class for creating presentations using a video projector"
9 HOMEPAGE="https://github.com/josephwright/beamer"
10 SRC_URI="https://github.com/josephwright/beamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2 FDL-1.2 LPPL-1.3c"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
15 IUSE="doc"
16
17 DEPEND="dev-texlive/texlive-latex"
18 RDEPEND=">=dev-tex/pgf-1.10
19         dev-texlive/texlive-latexrecommended
20         !dev-tex/translator"
21
22 S=${WORKDIR}/beamer-${PV}
23
24 src_prepare(){
25         default
26         rm -rf doc/licenses || die
27 }
28
29 src_install() {
30         insinto /usr/share/texmf-site/tex/latex/beamer
31         doins -r base
32
33         dodoc README.md
34
35         if use doc ; then
36                 docinto doc
37                 dodoc -r doc
38                 dosym "/usr/share/doc/${PF}/doc/" "${TEXMF}/doc/latex/beamer"
39         fi
40 }