profiles/arch/ia64/use.mask: add reference to python mask
[gentoo.git] / dev-tex / dot2texi / dot2texi-3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit latex-package
7
8 DESCRIPTION="Create graphs within LaTeX using the dot2tex tool"
9 HOMEPAGE="https://www.ctan.org/pkg/dot2texi"
10 # Taken from http://theory.uwinnipeg.ca/scripts/CTAN/macros/latex/contrib/dot2texi.zip
11 SRC_URI="mirror://gentoo/${P}.zip"
12
13 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE="pgf pstricks examples"
18
19 DEPEND="app-arch/unzip"
20 RDEPEND="pstricks? ( dev-texlive/texlive-pstricks )
21         pgf? ( dev-tex/pgf )
22         dev-texlive/texlive-latexrecommended
23         dev-texlive/texlive-latexextra
24         >=dev-tex/dot2tex-2.7.0"
25
26 TEXMF="/usr/share/texmf-site"
27
28 S="${WORKDIR}/${PN}"
29
30 src_install() {
31         latex-package_src_doinstall sty pdf
32
33         dodoc README
34         dodoc ${PN}.tex
35
36         if use examples; then
37                 docinto examples
38                 dodoc examples/*
39         fi
40 }