dev-qt/qtpaths: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-tex / currvita / currvita-0.9i-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit latex-package
7
8 DESCRIPTION="A LaTeX package for typesetting a curriculum vitae"
9 HOMEPAGE="https://www.ctan.org/tex-archive/macros/latex/contrib/currvita/"
10 # snapshot taken from
11 # ftp://ftp.dante.de/tex-archive/macros/latex/contrib/currvita.tar.gz
12 SRC_URI="mirror://gentoo/${P}.tar.gz"
13
14 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 IUSE=""
19
20 DEPEND="dev-texlive/texlive-langgerman"
21 RDEPEND="${DEPEND}"
22
23 TEXMF="/usr/share/texmf-site"
24
25 DOCS=( "README" )
26
27 S="${WORKDIR}/${PN}"
28
29 src_test() {
30         latex currvita.dtx || die "first test of currvita.dtx failed"
31         latex currvita.dtx || die "second test of currvita.dtx failed"
32         latex currvita.dtx || die "third test of currvita.dtx failed"
33         latex cvtest.tex || die "test of cvtest.tex failed"
34 }