dev-tcltk/iwidgets: MissingTestRestrict
[gentoo.git] / dev-tcltk / tktray / tktray-1.3.9.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils virtualx
7
8 MY_P="${PN}${PV}"
9
10 DESCRIPTION="System Tray Icon Support for Tk on X11"
11 HOMEPAGE="https://code.google.com/p/tktray/"
12 SRC_URI="https://tktray.googlecode.com/files/${MY_P}.tar.gz"
13
14 LICENSE="tcltk"
15 SLOT="0"
16 KEYWORDS="amd64 ~ppc ~sparc x86"
17 IUSE="debug threads test"
18
19 DEPEND="
20         >=dev-lang/tcl-8.4:0=
21         >=dev-lang/tk-8.4:0=
22         x11-libs/libXext"
23 RDEPEND="${DEPEND}"
24
25 S="${WORKDIR}/${MY_P}"
26
27 src_prepare() {
28         epatch "${FILESDIR}"/1.1-ldflags.patch
29 }
30
31 src_configure() {
32         source /usr/lib/tclConfig.sh
33         CPPFLAGS="-I${TCL_SRC_DIR}/generic ${CPPFLAGS}" \
34         econf \
35                 $(use_enable debug symbols) \
36                 $(use_enable threads)
37 }
38
39 src_test() {
40         Xemake
41 }