dev-tcltk/tktray: MissingTestRestrict
[gentoo.git] / dev-tcltk / tktray / tktray-1.3.9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils virtualx
7
8 MY_P="${PN}${PV}"
9
10 DESCRIPTION="System Tray Icon Support for Tk on X11"
11 HOMEPAGE="https://code.google.com/p/tktray/"
12 SRC_URI="https://tktray.googlecode.com/files/${MY_P}.tar.gz"
13
14 LICENSE="tcltk"
15 SLOT="0"
16 KEYWORDS="amd64 ~ppc ~sparc x86"
17 IUSE="debug threads test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="
21         >=dev-lang/tcl-8.4:0=
22         >=dev-lang/tk-8.4:0=
23         x11-libs/libXext"
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}/${MY_P}"
27
28 src_prepare() {
29         epatch "${FILESDIR}"/1.1-ldflags.patch
30 }
31
32 src_configure() {
33         source /usr/lib/tclConfig.sh
34         CPPFLAGS="-I${TCL_SRC_DIR}/generic ${CPPFLAGS}" \
35         econf \
36                 $(use_enable debug symbols) \
37                 $(use_enable threads)
38 }
39
40 src_test() {
41         Xemake
42 }