dev-tcltk: Remove *-fbsd KEYWORDS
[gentoo.git] / dev-tcltk / tcllib / tcllib-1.19.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit virtualx
7
8 DESCRIPTION="Tcl Standard Library"
9 HOMEPAGE="http://www.tcl.tk/software/tcllib/"
10 SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.xz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE="examples"
15 KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ~ppc s390 sparc x86 ~amd64-linux ~x86-linux"
16
17 RDEPEND="
18         dev-lang/tcl:0=
19         dev-tcltk/tdom
20         "
21 DEPEND="${RDEPEND}"
22
23 DOCS=(
24         ChangeLog DESCRIPTION.txt README-1.19.txt README.developer
25         devdoc/critcl-tcllib.txt devdoc/dirlayout_install.txt
26         devdoc/indexing.txt devdoc/installation.txt
27 )
28 HTML_DOCS=( devdoc/devguide.html devdoc/releaseguide.html )
29
30 src_prepare() {
31         default
32         if has_version ">=dev-lang/tcl-8.6.9"; then
33                 sed -i \
34                         -e "s|::hook::call|call|" \
35                         -e "s|::string::token::shell|shell|" \
36                         "${S}"/modules/hook/hook.test \
37                         "${S}"/modules/string/token_shell.test \
38                         || die
39         fi
40 }
41
42 src_test() {
43         USER= virtx emake test_batch
44 }
45
46 src_install() {
47         default
48
49         if use examples ; then
50                 for f in $(find examples -type f); do
51                         docinto $(dirname $f)
52                         dodoc $f
53                 done
54         fi
55 }