dev-tcltk/tcllib: keyworded 1.19 for ppc64, bug #708478
[gentoo.git] / dev-tcltk / tcllib / tcllib-1.19.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit virtualx
7
8 DESCRIPTION="Tcl Standard Library"
9 HOMEPAGE="http://www.tcl.tk/software/tcllib/"
10 SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.xz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE="examples"
15 KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         dev-lang/tcl:0=
20         dev-tcltk/tdom
21         "
22 DEPEND="${RDEPEND}"
23
24 DOCS=(
25         ChangeLog DESCRIPTION.txt README-1.19.txt README.developer
26         devdoc/critcl-tcllib.txt devdoc/dirlayout_install.txt
27         devdoc/indexing.txt devdoc/installation.txt
28 )
29 HTML_DOCS=( devdoc/devguide.html devdoc/releaseguide.html )
30
31 PATCHES=( "${FILESDIR}"/${P}-test.patch )
32
33 src_prepare() {
34         default
35         if has_version ">=dev-lang/tcl-8.6.9"; then
36                 sed -i \
37                         -e "s|::hook::call|call|" \
38                         -e "s|::string::token::shell|shell|" \
39                         "${S}"/modules/hook/hook.test \
40                         "${S}"/modules/string/token_shell.test \
41                         || die
42         fi
43 }
44
45 src_test() {
46         USER= virtx emake test_batch
47 }
48
49 src_install() {
50         default
51
52         if use examples ; then
53                 for f in $(find examples -type f); do
54                         docinto $(dirname $f)
55                         dodoc $f
56                 done
57         fi
58 }