Use https by default
[gentoo.git] / dev-tcltk / tcllib / tcllib-1.15-r2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils virtualx
8
9 DESCRIPTION="Tcl Standard Library"
10 HOMEPAGE="http://www.tcl.tk/software/tcllib/"
11 SRC_URI="
12         https://dev.gentoo.org/~jlec/distfiles/${P}-manpage-rename.patch.xz
13         https://dev.gentoo.org/~jlec/distfiles/${P}-test.patch.xz
14         mirror://sourceforge/tcllib/${P}.tar.bz2"
15
16 LICENSE="BSD"
17 SLOT="0"
18 IUSE="examples"
19 KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
20
21 RDEPEND="dev-lang/tcl:0="
22 DEPEND="${RDEPEND}"
23
24 DOCS=( DESCRIPTION.txt STATUS )
25
26 PATCHES=(
27         "${FILESDIR}"/${P}-tcl8.6-test.patch
28         "${WORKDIR}"/${P}-test.patch
29         "${WORKDIR}"/${P}-manpage-rename.patch
30         "${FILESDIR}"/${P}-XSS-vuln.patch
31 )
32
33 src_prepare() {
34         has_version ">=dev-lang/tcl-8.6" && \
35                 PATCHES+=( "${FILESDIR}"/${P}-test.patch )
36         epatch ${PATCHES[@]}
37 }
38
39 src_test() {
40         Xemake test_batch
41 }
42
43 src_install() {
44         default
45
46         dodoc devdoc/*.txt
47
48         dohtml devdoc/*.html
49         if use examples ; then
50                 for f in $(find examples -type f); do
51                         docinto $(dirname $f)
52                         dodoc $f
53                 done
54         fi
55 }