sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-tcltk / mysqltcl / mysqltcl-3.052-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="TCL MySQL Interface"
7 HOMEPAGE="http://www.xdobry.de/mysqltcl/"
8 SRC_URI="http://www.xdobry.de/mysqltcl/${P}.tar.gz"
9
10 LICENSE="HPND"
11 SLOT="0"
12 KEYWORDS="amd64 ~ppc ~sparc x86"
13 IUSE=""
14
15 DEPEND="
16         dev-lang/tcl:0=
17         dev-db/mysql-connector-c:0="
18 RDEPEND="${DEPEND}"
19 PATCHES=( "${FILESDIR}"/${PN}-3.05-ldflags.patch )
20 HTML_DOCS=( doc/mysqltcl.html )
21
22 src_prepare() {
23         default_src_prepare
24         sed -i 's/-pipe//g;s/-O2//g;s/-fomit-frame-pointer//g' configure || die
25 }
26
27 src_configure() {
28         econf --with-mysql-lib=$(mysql_config --variable=pkglibdir)
29 }