dev-tcltk/tkdnd: x86 stable wrt bug #704582
[gentoo.git] / dev-tcltk / itk / itk-4.0.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils multilib versionator
7
8 MY_PV=${PV/_beta/b}
9 ITCL_VERSION="$(get_version_component_range 1-2)"
10
11 DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
12 HOMEPAGE="http://incrtcl.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/project/incrtcl/%5Bincr%20Tcl_Tk%5D-4-source/Itcl%20${MY_PV}/${PN}${MY_PV}.tar.gz"
14 #SRC_URI="mirror://sourceforge/%5Bincr%20Tcl_Tk%5D-4-source/Itcl%20${MY_PV}/${PN}${MY_PV}.tar.gz"
15
16 IUSE=""
17 SLOT="0"
18 LICENSE="BSD"
19 KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
20
21 DEPEND="
22         >=dev-lang/tk-8.6:=
23         =dev-tcltk/itcl-${ITCL_VERSION}*"
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}/${PN}${MY_PV}"
27
28 src_prepare() {
29 #       epatch "${FILESDIR}"/${P}-install_data.patch
30         AT_M4DIR=.. eautoconf
31         sed 's:-pipe::g' -i configure || die
32 }
33
34 src_configure() {
35         source "${EPREFIX}"/usr/$(get_libdir)/itcl${ITCL_VERSION}*/itclConfig.sh || die
36         econf \
37                 --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
38                 --with-tk="${EPREFIX}"/usr/$(get_libdir) \
39                 --with-tclinclude="${EPREFIX}"/usr/include \
40                 --with-tkinclude="${EPREFIX}"/usr/include \
41                 --with-itcl="${ITCL_SRC_DIR}" \
42                 --with-x
43 }
44
45 src_compile() {
46         emake CFLAGS_DEFAULT="${CFLAGS}"
47 }
48
49 src_install() {
50         emake DESTDIR="${D}" install
51
52         dodoc license.terms
53
54         cat >> "${T}"/34${PN} <<- EOF
55         LDPATH="${EPREFIX}/usr/$(get_libdir)/${PN}${MY_PV}/"
56         EOF
57         doenvd "${T}"/34${PN}
58 }