dev-db/redis: Merge remote-tracking branch 'github/pr/13619'
[gentoo.git] / dev-scheme / guile-gcrypt / guile-gcrypt-0.2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="Guile bindings of libgcrypt"
9 HOMEPAGE="https://notabug.org/cwebber/guile-gcrypt"
10 SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="
18         >=dev-scheme/guile-2.0.11:=
19         dev-libs/libgcrypt:0=
20 "
21 DEPEND="${RDEPEND}"
22
23 S=${WORKDIR}/${PN}
24
25 src_prepare() {
26         default
27
28         # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
29         find "${S}" -name "*.scm" -exec touch {} + || die
30
31         # upstream tag on top of source tree. has no autogenerated files
32         eautoreconf
33 }