dev-qt/linguist-tools: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ruby / will_paginate / will_paginate-3.2.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_RECIPE_TEST="rspec"
8
9 RUBY_FAKEGEM_EXTRADOC="README.md"
10
11 inherit ruby-fakegem
12
13 DESCRIPTION="Most awesome pagination solution for Ruby"
14 HOMEPAGE="https://github.com/mislav/will_paginate/"
15
16 LICENSE="MIT"
17 SLOT="3"
18 KEYWORDS="~amd64 ~x86-macos"
19 IUSE=""
20
21 all_ruby_prepare() {
22         # Remove tests for unpackaged ORMs
23         rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
24 }
25
26 ruby_add_bdepend "
27         test? (
28                 dev-ruby/rails
29                 dev-ruby/mocha
30         )"