dev-ruby/net-sftp: also allow net-ssh:3
[gentoo.git] / dev-ruby / uconv / uconv-0.6.1-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 USE_RUBY="ruby22 ruby23 ruby24 ruby25"
6
7 inherit ruby-ng
8
9 DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
10 HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
11 SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
12 LICENSE="Ruby"
13 SLOT="0"
14 KEYWORDS="~amd64 ppc ppc64 x86"
15 IUSE=""
16
17 RUBY_S=${PN}
18
19 all_ruby_prepare() {
20         sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
21 }
22
23 each_ruby_configure() {
24         ${RUBY} extconf.rb || die
25 }
26
27 each_ruby_compile() {
28         emake V=1
29 }
30
31 each_ruby_install() {
32         emake V=1 DESTDIR="${D}" install
33 }
34
35 all_ruby_install() {
36         dodoc README*
37 }