dev-ruby/ruby-net-ldap: add 0.14.0
[gentoo.git] / dev-ruby / uconv / uconv-0.6.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 USE_RUBY="ruby19 ruby20"
7
8 inherit ruby-ng
9
10 DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
11 HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
12 SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
13 LICENSE="Ruby"
14 SLOT="0"
15 KEYWORDS="~amd64 ppc ppc64 x86"
16 IUSE=""
17
18 RUBY_S=${PN}
19
20 all_ruby_prepare() {
21         sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
22 }
23
24 each_ruby_configure() {
25         ${RUBY} extconf.rb || die
26 }
27
28 each_ruby_compile() {
29         emake V=1
30 }
31
32 each_ruby_install() {
33         emake V=1 DESTDIR="${D}" install
34 }
35
36 all_ruby_install() {
37         dodoc README*
38 }