dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-ruby / tzinfo / tzinfo-2.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
6
7 RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
8
9 RUBY_FAKEGEM_DOCDIR="doc"
10 RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
11
12 RUBY_FAKEGEM_GEMSPEC="tzinfo.gemspec"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="Daylight-savings aware timezone library"
17 HOMEPAGE="https://tzinfo.github.io/"
18 SRC_URI="https://github.com/tzinfo/tzinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
19
20 LICENSE="MIT"
21 SLOT="2"
22 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
23 IUSE=""
24
25 RDEPEND="sys-libs/timezone-data"
26 DEPEND="test? ( sys-libs/timezone-data )"
27
28 ruby_add_rdepend "dev-ruby/concurrent-ruby:1"
29 ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/minitest:5 )"
30
31 all_ruby_prepare() {
32         # Set the secure permissions that tests expect.
33         chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
34
35         # Skip safe tests since we cannot guarantee the correct permissions
36         # on directories for it to pass.
37         sed -e '/safe_test/askip "does not pass in gentoo test environment"' -i test/test_utils.rb || die
38
39         # Loosen test dependencies
40         sed -e '/rake/ s/12.2.1/12.2/' \
41                 -e '/simplecov/d' \
42                 -i Gemfile || die
43         sed -e '/TEST_COVERAGE/d' -i Rakefile || die
44 }
45
46 each_ruby_test() {
47         ${RUBY} -S bundle exec rake test || die
48 }