dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-ruby / tzinfo / tzinfo-2.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
8
9 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
10 RUBY_FAKEGEM_DOCDIR="doc"
11 RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
12
13 inherit ruby-fakegem
14
15 DESCRIPTION="Daylight-savings aware timezone library"
16 HOMEPAGE="https://tzinfo.github.io/"
17 SRC_URI="https://github.com/tzinfo/tzinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
18
19 LICENSE="MIT"
20 SLOT="2"
21 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
22 IUSE=""
23
24 RDEPEND="sys-libs/timezone-data"
25 DEPEND="test? ( sys-libs/timezone-data )"
26
27 ruby_add_rdepend "dev-ruby/concurrent-ruby:1"
28 ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/minitest:5 )"
29
30 all_ruby_prepare() {
31         # Set the secure permissions that tests expect.
32         chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
33
34         # Skip safe tests since we cannot guarantee the correct permissions
35         # on directories for it to pass.
36         sed -e '/safe_test/askip "does not pass in gentoo test environment"' -i test/test_utils.rb || die
37
38         # Loosen test dependencies
39         sed -e '/rake/ s/12.2.1/12.2/' \
40                 -e '/simplecov/d' \
41                 -i Gemfile || die
42         sed -e '/TEST_COVERAGE/d' -i Rakefile || die
43 }
44
45 each_ruby_test() {
46         ${RUBY} -S bundle exec rake test || die
47 }