dev-ruby/ruby-net-ldap: add 0.14.0
[gentoo.git] / dev-ruby / treetop / treetop-1.6.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby19 ruby20 ruby21"
8
9 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
10 RUBY_FAKEGEM_TASK_DOC=""
11 RUBY_FAKEGEM_DOCDIR="doc"
12 RUBY_FAKEGEM_EXTRADOC="README.md"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="Treetop is a language for describing languages"
17 HOMEPAGE="https://github.com/cjheath/treetop"
18 LICENSE="Ruby"
19
20 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
21 SLOT="0"
22 IUSE=""
23
24 ruby_add_bdepend "test? ( >=dev-ruby/rr-1.0 dev-ruby/activesupport )"
25 ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1:0"
26
27 all_ruby_install() {
28         all_fakegem_install
29
30         insinto /usr/share/doc/${PF}/examples
31         doins -r examples/*
32 }