dev-ruby/activejob: add 6.0.3.1
[gentoo.git] / dev-ruby / textpow / textpow-1.4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_RECIPE_TEST="rspec"
8
9 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
10 RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
11
12 inherit ruby-fakegem
13
14 SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15 DESCRIPTION="A library to parse and process Textmate bundles"
16 HOMEPAGE="http://textpow.rubyforge.org/"
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
21 IUSE=""
22
23 ruby_add_rdepend ">=dev-ruby/plist-3.0.1"
24
25 all_ruby_prepare() {
26         sed -i -e '/git ls-files/d' textpow.gemspec || die
27 }