dev-ruby/rails: add 6.0.3.1
[gentoo.git] / dev-ruby / text-hyphen / text-hyphen-1.4.1-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
7
8 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
9 RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
10
11 inherit ruby-fakegem
12
13 DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
14 HOMEPAGE="http://rubyforge.org/projects/text-format"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="amd64 hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
19 IUSE=""
20
21 ruby_add_bdepend "
22         test? (
23                 >=dev-ruby/hoe-2.8.0
24                 dev-ruby/test-unit:2
25         )"
26
27 all_ruby_prepare() {
28         sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
29 }