dev-qt/linguist-tools: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ruby / temple / temple-0.8.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 USE_RUBY="ruby23 ruby24 ruby25"
6
7 RUBY_FAKEGEM_TASK_DOC=""
8 RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
9
10 RUBY_FAKEGEM_TASK_TEST=""
11
12 inherit ruby-fakegem
13
14 DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
15 HOMEPAGE="https://github.com/judofyr/temple"
16
17 LICENSE="MIT"
18 SLOT="0.7"
19 KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86"
20 IUSE=""
21
22 ruby_add_bdepend "test? ( dev-ruby/bacon
23         dev-ruby/erubis
24         >=dev-ruby/tilt-2.0.1 )"
25
26 each_ruby_test() {
27         ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
28 }