dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-ruby / spreadsheet / spreadsheet-1.2.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 # Avoid the complexity of the "rake" recipe and run testrb-2 manually.
8 RUBY_FAKEGEM_RECIPE_TEST=none
9
10 RUBY_FAKEGEM_EXTRADOC="GUIDE.md History.md README.md"
11
12 RUBY_FAKEGEM_GEMSPEC="spreadsheet.gemspec"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="Ruby library to read and write spreadsheet documents"
17 HOMEPAGE="https://github.com/zdavatz/spreadsheet"
18 SRC_URI="https://github.com/zdavatz/spreadsheet/archive/${PV}.tar.gz -> ${P}.tar.gz"
19
20 LICENSE="GPL-3"
21 SLOT="0"
22 KEYWORDS="~amd64"
23 IUSE=""
24
25 ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
26 ruby_add_rdepend ">=dev-ruby/ruby-ole-1.0"
27
28 each_ruby_test() {
29         ruby-ng_testrb-2 --pattern='.+.rb' --exclude='suite\.rb' test/
30 }