dev-ruby/ruby-net-ldap: add 0.14.0
[gentoo.git] / dev-ruby / sparklines / sparklines-0.5.2-r6.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 USE_RUBY="ruby20 ruby21 ruby22"
7
8 RUBY_FAKEGEM_TASK_DOC=""
9
10 RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
11
12 inherit ruby-fakegem
13
14 DESCRIPTION="Create sparklines, small graphs to be used inline in texts"
15 HOMEPAGE="http://sparklines.rubyforge.org/"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86 ~x86-macos"
20 IUSE=""
21
22 RDEPEND="dev-ruby/rmagick"
23
24 ruby_add_bdepend test "dev-ruby/tidy_table dev-ruby/dust"
25
26 all_ruby_prepare() {
27         # Don't use deprecated rmagick require for compatibility with newer
28         # versions.
29         sed -i -e '/require/ s/RMagick/rmagick/' lib/sparklines.rb || die
30 }
31
32 each_ruby_test() {
33         ${RUBY} -I. test/test_all.rb || die
34 }