x11-terms/alacritty: 0.3.3-r1 amd64 stable
[gentoo.git] / dev-ruby / shoulda-matchers / shoulda-matchers-4.0.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 USE_RUBY="ruby24 ruby25 ruby26"
7
8 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
9
10 RUBY_FAKEGEM_RECIPE_TEST="none"
11
12 RUBY_FAKEGEM_EXTRAINSTALL="NEWS.md README.md"
13
14 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
15
16 RUBY_FAKEGEM_BINWRAP=""
17
18 inherit ruby-fakegem
19
20 DESCRIPTION="Making tests easy on the fingers and eyes"
21 HOMEPAGE="https://github.com/thoughtbot/shoulda-matchers"
22 SRC_URI="https://github.com/thoughtbot/shoulda-matchers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
23
24 LICENSE="MIT"
25 SLOT="3"
26 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
27 IUSE=""
28
29 ruby_add_rdepend ">=dev-ruby/activesupport-4.2.0:*"
30
31 all_ruby_prepare() {
32         sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
33 }