Merge remote-tracking branch 'remotes/anomaly256/389-ds-base'
[gentoo.git] / dev-ruby / shorturl / shorturl-1.0.0-r2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby20 ruby21 ruby22 ruby23"
8
9 RUBY_FAKEGEM_TASK_TEST=""
10 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
11 RUBY_FAKEGEM_TASK_DOC="doc"
12
13 RUBY_FAKEGEM_EXTRADOC="ChangeLog.txt README.rdoc TODO.rdoc"
14
15 inherit ruby-fakegem eutils
16
17 DESCRIPTION="A very simple library to use URL shortening services such as TinyURL or RubyURL"
18 HOMEPAGE="http://shorturl.rubyforge.org/"
19
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-macos"
23 IUSE=""
24
25 # All tests require network connectivity.
26 RESTRICT="test"
27
28 each_ruby_test() {
29         ${RUBY} -Ilib:test test/ts_all.rb || die "tests failed"
30 }
31
32 all_ruby_install() {
33         all_fakegem_install
34
35         if use doc; then
36                 # If the doc build fails, the doc directory might not exist
37                 pushd doc &>/dev/null || die "pushd doc failed"
38                 dohtml -r .
39                 popd &>/dev/null
40         fi
41 }