dev-ruby/sass-rails: add ruby22
[gentoo.git] / dev-ruby / sass-rails / sass-rails-5.0.5-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 USE_RUBY="ruby20 ruby21 ruby22"
6
7 RUBY_FAKEGEM_TASK_DOC=""
8 RUBY_FAKEGEM_EXTRADOC="README.md"
9
10 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
11
12 inherit ruby-fakegem versionator
13
14 DESCRIPTION="Official Ruby-on-Rails Integration with Sass"
15 HOMEPAGE="https://github.com/rails/sass-rails"
16 SRC_URI="https://github.com/rails/sass-rails/archive/v${PV}.tar.gz -> ${P}.tar.gz"
17
18 LICENSE="MIT"
19 SLOT="$(get_version_component_range 1-2)"
20 KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux"
21
22 IUSE=""
23
24 # Restrict tests for now since it is hard to set up the right
25 # environment with the correct ruby interpreter and Rails test
26 # application.
27 RESTRICT="test"
28
29 #ruby_add_bdepend "test? ( dev-ruby/sfl dev-ruby/bundler )"
30
31 ruby_add_rdepend ">=dev-ruby/sass-3.1:* =dev-ruby/sass-3*:*
32         =dev-ruby/railties-4*:* <dev-ruby/railties-6:*
33         >=dev-ruby/sprockets-rails-2.0:* <dev-ruby/sprockets-rails-4:*
34         >=dev-ruby/sprockets-2.8:* <dev-ruby/sprockets-4:*
35         >=dev-ruby/tilt-1.1:* <dev-ruby/tilt-3:*"
36
37 each_ruby_test() {
38         ${RUBY} -S bundle exec rake test || die
39 }