dev-ruby/pg: fix tests with postgresql 10
[gentoo.git] / dev-ruby / ruby_parser / ruby_parser-3.10.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 USE_RUBY="ruby21 ruby22 ruby23 ruby24"
7
8 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
9 RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
10
11 inherit ruby-fakegem
12
13 DESCRIPTION="A ruby parser written in pure ruby"
14 HOMEPAGE="https://github.com/seattlerb/ruby_parser"
15
16 LICENSE="MIT"
17 SLOT="3"
18 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
19 IUSE=""
20
21 ruby_add_rdepend ">=dev-ruby/sexp_processor-4.9.0:4
22         !<dev-ruby/ruby_parser-2.3.1-r1"
23
24 ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
25 ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 )"
26
27 DEPEND+=" test? ( dev-util/unifdef )"
28
29 all_ruby_prepare() {
30         # Remove reference to perforce method that is not in a released
31         # version of hoe-seattlerb.
32         #sed -i -e '/perforce/d' Rakefile || die
33         sed -i -e '/license/d' Rakefile || die
34         sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
35 }