www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-ruby / ruby-shout / ruby-shout-2.2.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
7
8 RUBY_FAKEGEM_TASK_TEST=""
9 RUBY_FAKEGEM_TASK_DOC=""
10
11 RUBY_FAKEGEM_EXTRADOC="README.textile"
12
13 inherit multilib ruby-fakegem
14
15 DESCRIPTION="A Ruby interface to libshout2"
16 HOMEPAGE="https://github.com/niko/ruby-shout"
17
18 LICENSE="Ruby"
19 SLOT="0"
20 KEYWORDS="~amd64 ~ppc x86"
21 IUSE=""
22
23 RDEPEND+=" >=media-libs/libshout-2.0"
24 DEPEND+=" >=media-libs/libshout-2.0"
25
26 each_ruby_configure() {
27         ${RUBY} -Cext extconf.rb || die "extconf failed"
28 }
29
30 each_ruby_compile() {
31         emake -C ext V=1
32 }
33
34 each_ruby_install() {
35         each_fakegem_install
36
37         ruby_fakegem_newins ext/${PN#ruby-}_ext$(get_modname) lib/${PN#ruby-}_ext$(get_modname)
38 }