sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-ruby / ruby-gdk3 / ruby-gdk3-3.3.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 inherit virtualx ruby-ng-gnome2
8
9 DESCRIPTION="Ruby GDK-3.x bindings"
10 KEYWORDS="~amd64 ~ppc ~x86"
11 IUSE=""
12
13 DEPEND+=" x11-libs/gtk+:3"
14 RDEPEND+=" x11-libs/gtk+:3"
15
16 ruby_add_rdepend "
17         ~dev-ruby/ruby-gdkpixbuf2-${PV}
18         ~dev-ruby/ruby-cairo-gobject-${PV}
19         ~dev-ruby/ruby-pango-${PV}
20 "
21
22 all_ruby_prepare() {
23         # Avoid unneeded dependency on test-unit-notify.
24         sed -i -e '/notify/ s:^:#:' \
25                 test/gdk-test-utils.rb || die
26
27         # Avoid compilation of dependencies during test.
28         sed -i -e '/Makefile/,/^  end/ s:^:#:' test/run-test.rb || die
29 }
30
31 each_ruby_configure() {
32         :
33 }
34
35 each_ruby_compile() {
36         :
37 }
38
39 each_ruby_test() {
40         virtx ${RUBY} test/run-test.rb
41 }
42
43 each_ruby_install() {
44         each_fakegem_install
45 }