dev-ruby/ruby-openid: x86 stable wrt bug #707880
[gentoo.git] / dev-ruby / ruby-clutter-gtk / ruby-clutter-gtk-3.3.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 inherit virtualx ruby-ng-gnome2
8
9 DESCRIPTION="Ruby Clutter bindings"
10 KEYWORDS="~amd64 ~ppc ~x86"
11 IUSE=""
12
13 RUBY_S=ruby-gnome2-all-${PV}/clutter-gtk
14
15 DEPEND+=" media-libs/clutter-gtk[gtk]"
16 RDEPEND+=" media-libs/clutter-gtk[gtk]"
17
18 ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}
19         >=dev-ruby/ruby-clutter-gdk-${PV}"
20 ruby_add_rdepend ">=dev-ruby/ruby-clutter-${PV}
21         >=dev-ruby/ruby-gtk3-${PV}"
22
23 all_ruby_prepare() {
24         # Avoid unneeded dependency on test-unit-notify.
25         sed -i -e '/notify/ s:^:#:' \
26                 ../gobject-introspection/test/gobject-introspection-test-utils.rb \
27                 ../clutter/test/clutter-test-utils.rb \
28                 test/clutter-gtk-test-utils.rb || die
29
30         # Avoid compilation of dependencies during test.
31         sed -i -e '/and have_make/,/^  end/ s:^:#:' test/run-test.rb || die
32 }
33
34 each_ruby_configure() {
35         :
36 }
37
38 each_ruby_compile() {
39         :
40 }
41
42 each_ruby_test() {
43         virtx ${RUBY} test/run-test.rb
44 }
45
46 each_ruby_install() {
47         each_fakegem_install
48 }