sys-apps/portage: remove old versions
[gentoo.git] / dev-ruby / rspec-expectations / rspec-expectations-3.7.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby22 ruby23 ruby24 ruby25"
6
7 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
8
9 RUBY_FAKEGEM_TASK_DOC=""
10 RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
11
12 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
17 HOMEPAGE="https://github.com/rspec/rspec-expectations"
18 SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
19
20 LICENSE="MIT"
21 SLOT="3"
22 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
23 IUSE=""
24
25 SUBVERSION="$(get_version_component_range 1-2)"
26
27 PATCHES=( "${FILESDIR}/${P}-ruby25.patch" )
28
29 ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
30         =dev-ruby/rspec-support-${SUBVERSION}*"
31
32 ruby_add_bdepend "test? (
33                 >=dev-ruby/rspec-mocks-3.2.0:3
34                 >=dev-ruby/rspec-support-3.5.0:3
35         )"
36
37 all_ruby_prepare() {
38         # Don't set up bundler: it doesn't understand our setup.
39         sed -i -e '/[Bb]undler/d' Rakefile || die
40
41         # Remove the Gemfile to avoid running through 'bundle exec'
42         rm -f Gemfile || die
43
44         # fix up the gemspecs
45         sed -i \
46                 -e '/git ls/d' \
47                 -e '/add_development_dependency/d' \
48                 "${RUBY_FAKEGEM_GEMSPEC}" || die
49 }