www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-ruby / rbnacl / rbnacl-7.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 USE_RUBY="ruby24 ruby25 ruby26"
7
8 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
9 RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
10
11 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
12
13 inherit ruby-fakegem
14
15 DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
16 HOMEPAGE="https://github.com/cryptosphere/rbnacl"
17
18 LICENSE="MIT"
19 SLOT="6"
20 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
21 IUSE=""
22
23 RDEPEND+=" dev-libs/libsodium"
24 DEPEND+=" test? ( dev-libs/libsodium )"
25
26 ruby_add_rdepend "dev-ruby/ffi"
27
28 all_ruby_prepare() {
29         sed -i -e '/coveralls/I s:^:#:' \
30                 -e '/bundler/ s:^:#:' \
31                 -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb
32 }