dev-ruby/json: remove unused patches
[gentoo.git] / dev-ruby / rails-html-sanitizer / rails-html-sanitizer-1.3.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
8 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
9
10 inherit ruby-fakegem
11
12 DESCRIPTION="Sanitize HTML fragments in Rails applications"
13 HOMEPAGE="https://github.com/rafaelfranca/rails-html-sanitizer"
14
15 LICENSE="MIT"
16 SLOT="1"
17 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
18 IUSE=""
19
20 ruby_add_rdepend ">=dev-ruby/loofah-2.3:0"
21
22 ruby_add_bdepend "test? ( dev-ruby/rails-dom-testing )"
23
24 all_ruby_prepare() {
25         # Avoid tests that depend on nokogiri patches to libxml2.
26         sed -i -e '/\(name_action\|attr\)_in_a_tag_in_safe_list_sanitizer/askip "libxml2"' test/sanitizer_test.rb || die
27 }
28
29 each_ruby_test() {
30         ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
31 }