dev-qt/linguist-tools: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ruby / rails-dom-testing / rails-dom-testing-2.0.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
6
7 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
8 RUBY_FAKEGEM_EXTRADOC="README.md"
9
10 inherit ruby-fakegem
11
12 DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
13 HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
14
15 LICENSE="MIT"
16 SLOT="2"
17 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86 ~amd64-linux"
18 IUSE=""
19
20 ruby_add_rdepend "
21         >=dev-ruby/activesupport-4.2.0:*
22         >=dev-ruby/nokogiri-1.6"
23
24 each_ruby_test() {
25         ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
26 }