dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ruby / rack-cache / rack-cache-1.10.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 # no documentation is generable, it needs hanna, which is broken
8 RUBY_FAKEGEM_RECIPE_DOC="none"
9
10 RUBY_FAKEGEM_TASK_TEST="none"
11
12 RUBY_FAKEGEM_EXTRADOC="CHANGES README.md doc/*"
13
14 RUBY_FAKEGEM_GEMSPEC="rack-cache.gemspec"
15
16 inherit ruby-fakegem
17
18 DESCRIPTION="Enable HTTP caching for Rack-based applications that produce freshness info"
19 HOMEPAGE="https://github.com/rtomayko/rack-cache"
20 SRC_URI="https://github.com/rtomayko/rack-cache/archive/v${PV}.tar.gz -> ${P}.tar.gz"
21
22 LICENSE="MIT"
23 SLOT="1.2"
24 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
25 IUSE=""
26
27 ruby_add_rdepend "dev-ruby/rack:*"
28
29 ruby_add_bdepend "test? (
30         >=dev-ruby/maxitest-3.4.0
31         >=dev-ruby/minitest-5.7.0:5
32         >=dev-ruby/mocha-0.13.0 )"
33
34 all_ruby_prepare() {
35         sed -i -e '/bundler/ s:^:#:' \
36                 -e "2i require 'timeout'" \
37                 test/test_helper.rb || die
38 }
39
40 all_ruby_prepare() {
41         sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
42         sed -i -e '/bundler/ s:^:#:' test/test_helper.rb || die
43 }
44
45 each_ruby_test() {
46         ${RUBY} -I.:lib:test -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
47 }