www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-ruby / pundit / pundit-1.1.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby23 ruby24 ruby25"
7
8 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
9 RUBY_FAKEGEM_RECIPE_DOC="doc"
10
11 inherit ruby-fakegem
12
13 DESCRIPTION="Object oriented authorization for Rails applications"
14 HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
22
23 ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
24         >=dev-ruby/activemodel-3.0.0 )"
25
26 all_ruby_prepare() {
27         sed -i -e "/pry/d" spec/spec_helper.rb || die
28 }