Use https by default
[gentoo.git] / dev-ruby / pdf-core / pdf-core-0.5.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby19 ruby20 ruby21"
8
9 RUBY_FAKEGEM_RECIPE_TEST="rspec"
10
11 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
12
13 inherit ruby-fakegem
14
15 DESCRIPTION="Implements low level PDF features for Prawn"
16 HOMEPAGE="https://github.com/prawnpdf/pdf-core/"
17
18 LICENSE="|| ( Ruby GPL-2 GPL-3 )"
19 SLOT="0"
20 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
21 IUSE="test"
22
23 ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1.1*
24         >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
25
26 all_ruby_prepare() {
27         sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
28 }