dev-qt/linguist-tools: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-ruby / net-ssh / net-ssh-5.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
7
8 RUBY_FAKEGEM_DOCDIR="doc"
9 RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
10 RUBY_FAKEGEM_EXTRAINSTALL="support"
11
12 inherit ruby-fakegem
13
14 DESCRIPTION="Non-interactive SSH processing in pure Ruby"
15 HOMEPAGE="https://github.com/net-ssh/net-ssh"
16 SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
17
18 LICENSE="GPL-2"
19 SLOT="5"
20 KEYWORDS="amd64 ~arm ppc ppc64 x86"
21 IUSE="ed25519 test"
22
23 ruby_add_rdepend "virtual/ruby-ssl ed25519? ( dev-ruby/ed25519 dev-ruby/bcrypt_pbkdf )"
24 ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
25
26 all_ruby_prepare() {
27         # Avoid bundler dependency
28         sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
29 }
30
31 src_test() {
32         # prevent tests from trying to connect to ssh-agent socket and failing
33         unset SSH_AUTH_SOCK
34         if ! use ed25519; then
35                 export NET_SSH_NO_ED25519=true
36         fi
37         ruby-ng_src_test
38 }