dev-ruby/xml-simple: add ruby25
[gentoo.git] / dev-ruby / net-ssh / net-ssh-3.2.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby20 ruby21 ruby22 ruby23"
7
8 RUBY_FAKEGEM_TASK_TEST=""
9
10 RUBY_FAKEGEM_DOCDIR="doc"
11 RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
12 RUBY_FAKEGEM_EXTRAINSTALL="support"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="Non-interactive SSH processing in pure Ruby"
17 HOMEPAGE="https://github.com/net-ssh/net-ssh"
18 SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
19
20 LICENSE="GPL-2"
21 SLOT="3"
22 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
23 IUSE="test"
24
25 ruby_add_rdepend "virtual/ruby-ssl"
26 ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
27
28 each_ruby_test() {
29         ${RUBY} -Ilib:test test/test_all.rb || die "Tests failed."
30 }