Merge the GLEP 67 transition changes
[gentoo.git] / dev-ruby / mocha / mocha-0.14.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 USE_RUBY="ruby19 ruby20 ruby21 ruby22"
7
8 RUBY_FAKEGEM_TASK_TEST="test:units"
9
10 RUBY_FAKEGEM_TASK_DOC="yardoc"
11 RUBY_FAKEGEM_DOCDIR="doc"
12 RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
13
14 RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
15
16 inherit ruby-fakegem
17
18 DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
19 HOMEPAGE="http://gofreerange.com/mocha/docs/"
20
21 LICENSE="MIT"
22 SLOT="0.14"
23 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
24 IUSE=""
25
26 ruby_add_bdepend "
27         doc? ( dev-ruby/yard )
28         test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
29
30 ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
31
32 all_ruby_prepare() {
33         sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
34         sed -i -e '20irequire "mocha/setup"' test/test_helper.rb || die
35 }