dev-util/kdevelop-python: Add missing RDEPEND
[gentoo.git] / dev-ruby / mechanize / mechanize-2.7.3-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby20 ruby21 ruby22"
7
8 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
9
10 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc EXAMPLES.rdoc GUIDE.rdoc README.rdoc"
11
12 inherit ruby-fakegem
13
14 DESCRIPTION="A Ruby library used for automating interaction with websites"
15 HOMEPAGE="https://github.com/sparklemotion/mechanize"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
20 IUSE=""
21
22 ruby_add_bdepend ">=dev-ruby/hoe-3.7
23         test? ( dev-ruby/minitest:5 )"
24 ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4-r1
25         >=dev-ruby/net-http-digest_auth-1.1.1
26         >=dev-ruby/net-http-persistent-2.5.2
27         >=dev-ruby/ntlm-http-0.1.1
28         >=dev-ruby/webrobots-0.0.9
29         >=dev-ruby/http-cookie-1.0.2
30         >=dev-ruby/mime-types-2.0
31         >=dev-ruby/domain_name-0.5.1"
32
33 all_ruby_install() {
34         all_fakegem_install
35
36         docinto examples
37         dodoc examples/* || die
38 }