dev-ruby/coffee-script: add ruby24
[gentoo.git] / dev-ruby / maruku / maruku-0.7.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby21 ruby22 ruby23"
7
8 RUBY_FAKEGEM_RECIPE_TEST="rspec"
9
10 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
11 RUBY_FAKEGEM_DOCDIR="doc"
12 RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
13         docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
14         docs/proposal.md"
15 RUBY_FAKEGEM_EXTRAINSTALL="data"
16
17 inherit ruby-fakegem
18
19 DESCRIPTION="A Markdown-superset interpreter written in Ruby"
20 HOMEPAGE="https://github.com/bhollis/maruku"
21
22 LICENSE="GPL-2"
23 SLOT="0"
24 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
25 IUSE="highlight test"
26
27 ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff )"
28 ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
29
30 DEPEND+=" test? ( app-text/blahtexml )"
31
32 all_ruby_prepare() {
33         sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
34 }
35
36 pkg_postinst() {
37         elog
38         elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
39         elog "you want to use --pdf with Maruku. You may also want to emerge"
40         elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
41         elog
42 }