dev-ruby/rails: add 6.0.3.1
[gentoo.git] / dev-ruby / loquacious / loquacious-1.9.1-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
7
8 RUBY_FAKEGEM_RECIPE_TEST="rspec"
9
10 RUBY_FAKEGEM_TASK_DOC=""
11 RUBY_FAKEGEM_DOCDIR="doc"
12
13 RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
14
15 inherit ruby-fakegem
16
17 DESCRIPTION="Descriptive configuration files for Ruby written in Ruby"
18 HOMEPAGE="https://github.com/TwP/loquacious"
19
20 IUSE=""
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~x86"
24
25 all_ruby_compile() {
26         if use doc; then
27                 rdoc lib || die "Documentation generation failed."
28         fi
29 }
30
31 all_ruby_install() {
32         all_fakegem_install
33
34         docinto examples
35         dodoc examples/*
36 }