dev-ruby/listen: amd64 stable
[gentoo.git] / dev-ruby / listen / listen-1.3.1-r4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby23 ruby24 ruby25"
7
8 RUBY_FAKEGEM_RECIPE_TEST="rspec"
9
10 RUBY_FAKEGEM_TASK_DOC=""
11 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
12
13 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
14
15 inherit ruby-fakegem
16
17 DESCRIPTION="Listens to file modifications and notifies you about the changes"
18 HOMEPAGE="https://github.com/guard/listen"
19 SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
20
21 LICENSE="MIT"
22 SLOT="1"
23 KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x64-macos"
24 IUSE=""
25
26 ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
27
28 all_ruby_prepare() {
29         sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
30         # Drop failing test
31         sed -i -e '/#85/,+17d' spec/listen/directory_record_spec.rb || die
32
33         # Drop dependencies for file system events not available on Gentoo.
34         sed -i -e '/\(fsevent\|kqueue\)/d' ${RUBY_FAKEGEM_GEMSPEC} || die
35 }