www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-ruby / jbuilder / jbuilder-2.10.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_TASK_TEST="TRAVIS=true test"
8
9 RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
10
11 inherit ruby-fakegem
12
13 DESCRIPTION="Create JSON structures via a Builder-style DSL"
14 HOMEPAGE="https://github.com/rails/jbuilder"
15
16 LICENSE="MIT"
17 SLOT="2"
18 KEYWORDS="~amd64"
19 IUSE=""
20
21 ruby_add_rdepend ">=dev-ruby/activesupport-5.0.0:*"
22
23 ruby_add_bdepend "test? (
24         >=dev-ruby/railties-5.0.0
25 )"
26
27 all_ruby_prepare() {
28         sed -i -e '/bundler/ s:^:#:' Rakefile test/test_helper.rb || die
29 }