dev-ruby/nokogiri: keyword ~arm64
[gentoo.git] / dev-ruby / i18n / i18n-0.6.11-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby20 ruby21 ruby22 ruby23"
7
8 RUBY_FAKEGEM_RECIPE_TEST="test"
9 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
10 RUBY_FAKEGEM_EXTRADOC="README.md"
11
12 inherit ruby-fakegem
13
14 DESCRIPTION="Add Internationalization support to your Ruby application"
15 HOMEPAGE="http://rails-i18n.org/"
16
17 LICENSE="MIT"
18 SLOT="0.6"
19 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
20 IUSE=""
21
22 RUBY_PATCHES=( ${PN}-0.7.0-frozen-classes.patch )
23
24 ruby_add_bdepend "test? ( dev-ruby/activesupport
25         dev-ruby/mocha:1.0
26         dev-ruby/test_declarative
27         dev-ruby/minitest:0 )"
28
29 each_ruby_test() {
30         ${RUBY} -w -Ilib -Itest test/all.rb || die
31 }
32
33 all_ruby_prepare() {
34         #Bundler isn't really necessary here, and it doesn't work with jruby
35         #Tests fail for jruby with >=mocha-0.13 unless we also include the
36         #test-unit gem. jruby also requires an explicit require of 'set'.
37         #Tests are cannot be run in random order, so use a minitest version that does not do this.
38         sed -i -e "/require 'bundler\/setup'/ s:^:#:" \
39                 -e '1irequire "set"; gem "minitest", "~> 4.0"' \
40                 -e "/require 'test\\/unit'/i gem 'test-unit'" test/test_helper.rb || die
41 }