Merge remote-tracking branch 'remotes/sbraz/pysrt'
[gentoo.git] / dev-ruby / hoe-seattlerb / hoe-seattlerb-1.3.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 USE_RUBY="ruby19 ruby20 ruby21 ruby22"
7
8 # no tests present
9 RUBY_FAKEGEM_TASK_TEST=""
10
11 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
12 RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="Hoe plugins providing tasks used by seattle.rb"
17 HOMEPAGE="http://seattlerb.rubyforge.org/hoe-seattlerb"
18
19 LICENSE="MIT"
20 SLOT="0"
21 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
22 IUSE=""
23
24 all_ruby_prepare() {
25         # Not a real fix, but otherwise USE="doc" breaks and defaulte license is MIT
26         sed -i -e "/license/d" Rakefile || die
27 }