13a8945c624edf0ce073fa3037313d76d614485f
[gentoo.git] / dev-ruby / hiera / hiera-3.0.1-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby19 ruby20 ruby21 ruby22"
8
9 RUBY_FAKEGEM_RECIPE_TEST="rspec"
10
11 RUBY_FAKEGEM_TASK_DOC=""
12 RUBY_FAKEGEM_EXTRADOC="README.md"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="A simple pluggable Hierarchical Database"
17 HOMEPAGE="http://projects.puppetlabs.com/"
18
19 LICENSE="Apache-2.0"
20 SLOT="0"
21 IUSE=""
22 KEYWORDS="~amd64 ~hppa ~x86"
23
24 ruby_add_bdepend "test? ( dev-ruby/mocha )"
25
26 ruby_add_rdepend "dev-ruby/json
27                 dev-ruby/deep_merge"
28
29 all_ruby_prepare() {
30         # Our json package is either the compiled version or the pure
31         # version. Fix gemspec accordingly.
32         sed -i -e 's/json_pure/json/' ../metadata || die
33 }