Merge remote-tracking branch 'remotes/lilrc/bug-557160'
[gentoo.git] / dev-ruby / hashr / hashr-2.0.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 USE_RUBY="ruby20 ruby21 ruby22"
8
9 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
10
11 RUBY_FAKEGEM_TASK_DOC=""
12 RUBY_FAKEGEM_EXTRADOC="README.md"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="Simple Hash extension to make working with nested hashes easier and less error-prone"
17 HOMEPAGE="https://github.com/svenfuchs/hashr"
18
19 LICENSE="MIT"
20 SLOT="0"
21 KEYWORDS="~amd64"
22 IUSE=""
23
24 all_ruby_prepare() {
25         sed -i -e '1i require "spec_helper"' spec/hashr/delegate/conditional_spec.rb || die
26 }