dev-ruby/ruby-net-ldap: add 0.14.0
[gentoo.git] / dev-ruby / gruff / gruff-0.6.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 USE_RUBY="ruby19 ruby20 ruby21 ruby22"
7
8 RUBY_FAKEGEM_TASK_DOC=""
9
10 RUBY_FAKEGEM_DOCDIR="doc"
11 RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.md RELEASE.md"
12
13 RUBY_FAKEGEM_EXTRAINSTALL="assets rails_generators"
14
15 inherit ruby-fakegem
16
17 DESCRIPTION="Beautiful graphs for one or multiple datasets"
18 HOMEPAGE="https://github.com/topfunky/gruff"
19
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="amd64 x86 ~x86-macos"
23 IUSE=""
24
25 RUBY_PATCHES=(
26         ${PN}-0.3.6-spider.patch
27 )
28
29 # imagemagick is an indirect dependency through rmagick. However, for
30 # gruff to work properly imagemagick needs to be compiled with truetype
31 # support and this cannot be expressed in the rmagick dependency. Tests
32 # also require imagemagick to have jpeg and png support.
33 DEPEND="${DEPEND} test? ( media-gfx/imagemagick[jpeg,png,truetype,webp] )"
34 RDEPEND="${RDEPEND} media-gfx/imagemagick[truetype]"
35
36 ruby_add_rdepend ">=dev-ruby/rmagick-2.13.4"
37 ruby_add_bdepend "
38         test? (
39                 dev-ruby/hoe
40                 dev-ruby/test-unit
41         )"
42
43 each_ruby_test() {
44         ruby-ng_testrb-2 test/test_*.rb
45 }